Overview of a Sunkko 788+ Welder

So, you find yourself needing to spot weld a battery pack (or something else) together.  And, spot welders are expensive, and most people end up building DIY devices, but there’s this little gizmo (and it’s siblings) all over the internet.  Alibaba, eBay, Amazon… it’s a common item that claims to be a decent spot welder. It runs about $200 shipped to the US.![](upload://7deHyOpyYpwRN6MqUFGRg2hexWs.gif)  Be sure you get the 110v one - most of them run on 220v (unless you have 220v power, of course).

This is a companion discussion topic for the original entry at https://www.sevarg.net/2015/05/16/overview-of-sunkko-788-welder/

(Comments from Blogger)

2015-07-18 by Sparky4460

I use my 788+ for the first time to make a battery pack. I have to admit it worked very well. After reading your blog I was very careful not to push it very hard and wore PPE particularly safety glasses. I left the “course current adjustment knob” at zero and adjusted my current digitally at 65. I set the number of pulses to 2. That seemed to make a pretty good weld. I also ordered some spare triacs to have on hand in case mine decides to give out. I discovered that they are hard to find in the United States in low quantity so I had to order them from China. There were not very expensive. Thanks for your blog. It helped much more than their manual.

2015-08-06 by Anar

I plug in my device and when I turn it on, the socket’s fuse goes off. What is the problem? Could you please help me?

2015-08-07 by Sparky4460

Documentation is not very good so first question is did you get the right voltage? Comes in two versions. 240V and 120 V. What did you get and what do you need?

2015-08-07 by Russell Graves

At the bottom of http://syonyk.blogspot.com/2015/05/notes-on-sunkko-788-battery-spot-welder.html I have a suggestion from someone who has the same issue to switch to a Type C breaker instead of a Type B breaker on the circuit - it helps with the inrush current (which is very high).

I’ve also seen some people create bypasses with resistors to handle this, but I don’t know details about that.

2015-11-16 by Electronicpartsmaster

Thank you very much for this post I am think of buying one of these and seeing the inside is very helpful.

2015-11-16 by Electronicpartsmaster

I would like to know more about this also could you send me some additional images. I would be happy to share what I learn with you!

2015-11-16 by Russell Graves

All the good photos I have are up here. You should be able to click the images for higher res versions.

2015-12-05 by Unknown

Hello, the welds are good. Too bad that I just tried the charger I heard a low, the charger does not work now. The disassembled and I saw that under the radiator there is a MIP0224SY, it could be broken? Thank you

2015-12-05 by Russell Graves

Under the heat sink, there should be a triac of some sort. Mine failed and I had to replace it: http://syonyk.blogspot.com/2015/05/sunkko-788-welder-failure-and-repair.html

The part number you mention is not the same as the one I had, but it’s a power handling device, and it’s certainly worth replacing it to see if it resolves the issue.

2015-12-09 by Unknown

Hi there we have purchased this weirder and every time try to use it it blows the whole house trip switches . Any ideas why. The instructions are all in Chinese .

2015-12-09 by Russell Graves

It’s probably because the inrush current on this welder is insanely high.

Are you referring to “whole house trip switches” as the individual circuit breaker it’s on, or the whole house breaker? It shouldn’t be tripping the whole house breaker, but it’s known for tripping the breaker it’s on. You may have an improvement switching from a Type C breaker instead of the more common Type B breaker.

You can also try leaving the unit turned on and resetting the breaker. This works for some people.

They’re not particularly well designed units, sadly.

2016-01-25 by NarkyMark

Hi, After constant MCB trips I finally managed to fire this thing up by leaving the unit on and then flipping the breaker…I then did aboit 5 cell welds and now it’s dead…Could this be the Triac you mention? Any way I could test this? Thanks in advance. Mark

2016-01-25 by Russell Graves

It’s worth taking a look.

The symptoms on mine when the triac died were that the unit powered on, and the LED digits would dim when I tried to weld, but nothing happened. There was also a loud bang when it let go.

It’s worth taking a look. My triac had a huge obvious hole in it.

2016-01-25 by NarkyMark

Yes, once I watched your video I realised that the Triac was the fault…It turned out that although mine hadnt blown, one of the legs on the Triac had actually melted and there was a gap - Some solder later I finally bridged the gap and it’s up and running again. I suggest to anyone new to these (as somebody before me already has) is turn the course current dial to zero and use the led adjustment - I am using 60 - twin pulse and all seems fine for now using 0.15mm Nickel. I wonder if upgrading the Triac would help? One thing for sure this thing isn’t for the faint hearted or a PAT test :slight_smile: - Thanks for your help & video Russell!

2016-01-25 by Russell Graves

Well, that sounds about like Chinese QC.

When mine blew up, I was playing with the current adjustment knob as well. I leave it set to 0, and weld on “70 2” for 0.15mm nickel strip with great success. I still don’t know what that knob does other than seem to be correlated with blowing up triacs.

When I replaced the traic in my unit, I actually hung it off the back of the board. The stock location is folded against the front of the board, pressed against the front casing. On the theory that this was less than optimal for cooling, I installed the replacement one hanging out the back, into the open air around the transformer. I don’t know if this helped or not, or if I just had a bad triac to start with, but I’ve welded up a few packs now with no trouble. I’m also quite gentle on the unit now - I let it cool every few batteries worth of welding.

At least on my unit, I think many of the problems are related to it being the 110v version. I suspect the engineering used to go from a 220v unit to a 110v unit involved changing the power converter circuitry to the board, and possibly changing the transformer. Possibly not. But, in either case, I expect the 110v unit to be handling twice the current of the 220v unit with no change in anything other than the bare minimum needed to make this work.

2016-02-03 by Unknown

Hello all, my welder which I purchased last year is still yet to weld its first cell. I had similar symptoms as Russell mentioned above, where initially the display would dim when attempting to weld. After a lengthy and challenging email conversation with a lady from China, I decided to investigate further with her help… Long story short is that it too did blow up and resulted in the electrics tripping. Since then I’ve had no further support.

Could you please post a link of a suitable triad replacement? For the sake of a few quid it’s worth it trying to repair it oppose to having a $170 lump of metal.

I also have a video of it blowing up with the covers off, if it’s of interest to people I can forward it on.


2016-02-03 by Russell Graves

azman -

Just grab the model number off your blown triac and see what you can find. eBay is a good source.

Mine has a BCR30AM triac - I believe they may be different between units, but this one will probably work if yours has blown all it’s identifying numbers off.

I bought a 5 pack of replacement triacs on eBay, since I wasn’t sure at the time if the triac blowing is a regular occurrence or just a one time event. I’ve not blown another one yet, though I’m rather gentle with the unit now and the triac is hanging out the back of the board into the open air near the transformer.

Details of my repair process are documented elsewhere on my blog - http://syonyk.blogspot.com/2015/05/sunkko-788-welder-failure-and-repair.html has photos of the repair.

When you do get it repaired, I suggest leaving the current knob alone. I don’t know what it does, but I was messing around with it shortly before things blew up. I weld with the current knob firmly at 0 and “70 2” as my digital display settings. It nicely welds 0.15mm nickel strip onto cells without any signs of excess energy.

2016-05-04 by Speamaker

Hi Russel,

I just try the same unit.
At first, the unit works well for some weld. But after that, it causing a trip on the mcb everytime I turn on the welding switch. For the charger part, it is ok when I turn on the charger switch.
Do you have idea that causing this problem?

Another thing, it is ok if the two soldering tip accidentally connected when we install that two welding tip? Because, seem that I just unaware that two tips connected after installation.

Thanks and Regards,

2016-06-03 by Unknown

Do you think the 788H model is better built ?

2016-08-13 by Unknown


My unit just arrived. I have the 220V version (live in EU/NL) and have the same Circuit Breaker problem (16A trips). Not sure if the unit is defective or if it’s just the inrush current. One other thing I noticed, is when I switch on the charger, I see some blinking (for about 10 sec) an 3.Eo 00.00 on the Amps and Voltage display before it shows 0.00 00.00 Is that considered normal?

Cheers, Henk

2016-12-20 by SouthPark

What you are seeing is confirmed. I see something like that too. But mine didn’t go as long as 10 seconds. Maybe 3 to 5 seconds. However, I blew up my 788H when I inadvertently switched the weld (green) switch on before the display had time to change to ‘0.00 00.00’ (after switching on the main red switch). I’ve ordered a second 788H from ebay (in case I can’t fix my currently dead one). The dead one has a blown surface mount rectifier IC near the molex-like 4-pin connector, and on the other side of the circuit board is a blown 5D-9 thermistor… busted in half. They blew up after all LEDs went ‘off’ (disappeared), and when I switched the MAIN switch from ON to OFF… yes… on to off, and not the other way around. In fact, I had though that the fuse had blown, so was very surprised to see a big flash when I switched the main switch from on to off.

2017-02-03 by Unknown

exactly the same thing happened to me when I turned on the charger. something “popped” and now the only thing that comes on is the welder only. not a biggie for me since I do not trust the charger that comes with it. I bought it mainly for the welder.

2017-02-03 by Unknown

Mr Russell,

Just wanted to say thanks for taking the time to post your blog. If I could, I’ll buy you lunch. Thanks for sharing your findings.

2017-02-03 by Russell Graves

Rob - if you run across any interesting cheap gizmos you’d like me to tear down, I’m happy to do some analysis. Contact form is on the right if you want to ship me something.

I’m glad you find it useful. It’s an esoteric corner of the internet I lurk in.

2017-04-05 by Unknown

I just received my 788H (eBay, AUD $203 delivered to Australia), connected it in the kitchen (240VAC, 20Amp breaker), there is a thump when it turns on and the UPS’s in the office on another circuit squeal in annoyance! I welded a few tabs, seems to work fine (on steel, not on the tinned copper protection circuit boards on the back on some 18650!).

I then opened it up and added one of these: http://au.rs-online.com/web/p/thermistors/5167760/
(Not bad, $3.92 and free delivery, ordered online Wednesday, delivered 9am Thursday)

I installed it internally in line with the active, just after the fuse.

Turned it on, no thump or squeals at all, smooth as can be!
Thermal camera showed it at 80C just after turn on, rapidly dropping to 70C

I then did a few more welds, didn’t appear to be any change in quality.

Early days, but looking good.

2017-04-06 by Unknown

David Varley,

Can you post some pics of what exactly you did please? I am a novice when it comes to messing with electronics.

Cheers mate!


2017-06-06 by MCP

i put an 22ohm NTC after fuse. now it works perfekt

2017-07-28 by Unknown

Hi guys,
Installed the thermistor that David Varley proposed (RS Pro Thermistor 50Ω) in my 788H 230v since I have the same problem with it blowing my 16Amps fuse.
After installation, the first start went nice and smooth, no thumps, no blown fuse…
Sencond start, the thermistor blew :frowning:
Any ides? Wrong thermistor, bad thermistor or what?



2017-08-09 by NarkyMark

Hi Peter,

I am not sure about your thermistor but to overcome the fuse tripping I would suggest you try and find a Type D 16A breaker for your consumer unit. These are designed to withstand the short surges of higher inductance that the spot welders produce. It’s not so much a fault with the welders but more that the Type B and C breakers are designed for domestic appliance only surges.




2017-08-19 by Unknown

i: Great article(s)

What triac did you use?

Do you know a replacement source for the electrodes?

Have Ryobi 40 v lawnmower. Battery is dying. All UTUBE dis-assemblies are not helpful. I have supplies of the excellent new Panasonic NCR18650GA
… and appropriate new bms bds.

The ryobi battery uses 4 contacts…but the bms seems to sense only when the ON button AND the safety “kill lever” are activated.

I do have a schematic from the net (below)…but not sure I understand it. I would just like to build a new battery with bms. But B+ and B- do not go directly to the lawnmower wiring. But rather a M+ and M- go to the motor. It looks like when the “kill lever is released…the motor is shorted to provide a brake. The “key” is shown as connected to the li-pos inside the battery case. It is rather wired within the lawn mower. I wish folks would provide actual schematics.

Any help is appreciated.


ryobi 40 v battery wiring diagram - Google Search

2017-09-10 by Pablo

Hi friend… I have 788 and works fine at this momment. But I have a question… I would like to install the “remote” welder (it´s on other sunkko models, how 709). I found this https://es.aliexpress.com/store/product/SUNKKO-HB-71A-Battery-spot-welding-pen-use-for-polymer-battery-welding-for-s709a-s719a-welder/1018848_32670115161.html?spm=a219c.search0204.3.9.tf3Nz9&s=p&ws_ab_test=searchweb0_0%2Csearchweb201602_1_10152_10065_10151_10068_10307_10301_10137_10303_10060_10155_10154_10056_10055_10054_10059_100031_10099_10338_10103_10102_440_10109_10052_10053_10142_10107_10050_10051_10326_10084_10083_10080_10082_10081_10110_10111_10176_10112_10113_10114_143_10312_10313_10184_10314_10078_10079_10073%2Csearchweb201603_19%2CppcSwitch_5_ppcChannel&btsid=230a9aea-6cee-49d9-9920-46479cfd7864 and I was thinking to connect, when I need, to the main poles (removeing the screws and attaching there… and after that it´s supposed to I can use pedal for force spot). What do you think? will it work? Thanks

2017-12-21 by Eric Lee

Can i ask question?
788+ has microswitch(Circuit Board Shots second picture)
Do you know switch spec? (Ex: 120V 1A)
My spot welder broken microswitch, but can’t find.
If you can find, Please reply. Thank you.

2018-06-26 by Unknown

Make sure you are using a circuit with a 20A breaker as specified on the last page in the owners manual. I haven’t had any issues tripping the 20A breaker.

2020-03-03 by Unknown

Hello I got my device today and I wanted to charge a 36 v battery, but there is an SMd exploded and I can’t see the number of it, divce is sunkko 788h, can you pls send me a picture with good quality of the circuit board, so I know the number of it ?

2020-03-03 by Russell Graves

I’m not going to disassemble mine again, sorry. Unless it blows up. You should talk to the seller if yours is defective.